技术
成就梦想!

Zabbix编译常见报错解决办法

一、CentOS编译报错

以下操作可能需要第三方源,参考此进行安装第三方Yum源
rpm -ivh  http://ftp.sjtu.edu.cn/fedora/epel/6/x86_64/epel-release-6-8.noarch.rpm
1、configure: error: Jabber library not found
#yum install iksemel-devel即可

2、configure: error: LIBXML2 library not found
#yum install libxml2-devel

3、configure: error: unixODBC library not found
#yum install unixODBC-devel

4、configure: error: Invalid OPENIPMI directory - unable to find ipmiif.h
#yum install OpenIPMI-devel

5、configure: error: Unable to find "javac" executable in path
#yum install java-1.6.0-openjdk-devel

6、configure: error: Curl library not found
#yum install curl-devel

二、Ubuntu编译报错

1、configure: error: MySQL library not found
# apt-get install libmysqlclient-dev

2、configure error: Invalid Net-SNMP directory - unable to find net-snmp-config
# apt-get install snmp snmpd libsnmp-dev

3、configure: error: Curl library not found
#apt-get install php5-curl -y

4、configure: error: LIBXML2 library not found
#apt-get install libcurl4-gnutls-dev

5、在profile中不能设置中文:
"You are not able to choose some of the languages, because locales for them are not installed on the web server."
两个问题排查一下:
a)检查zabbix的php文件:/usr/share/zabbix/include/locales.inc.php
检查“ 'zh_CN' => array('name' => _('Chinese (zh_CN)'),        'display' => true) ”display的值是否为true
b)执行命令:dpkg-reconfigure locales,检查是否安装中文包,如果没有,安装中文包:apt-get install -y language-pack-kde-zh-hans

三、其他常规编译报错

以下摘自网络:
1、configure: error: No curses/termcap library found
网上有的说法是:
--with-named-curses-libs=/usr/lib/libncursesw.so.5
其实是不对的,虽然能解决configure的错误,但是make的时候会提示错误,正确的做法应该是
yum -y install ncurses-devel
debian: apt-get install libncurses5-dev

2、configure: error: xml2-config not found
yum -y install libxml2-devel
debian:apt-get install libxml2-dev

3、configure: error: Cannot find OpenSSL's
yum -y install openssl-devel

4、configure: error: libjpeg.(a|so) not found
yum -y install gd
yum -y install gd-devel
debian:apt-get install libjpeg-dev

5、configure: error: libpng.(a|so) not found.
apt-get install libpng12-dev

6、configure: error: cannot find output from lex; giving up
yum -y install flex

7、configure: error: mod_deflate has been requested but can not be built due to prerequisite failures
yum -y install zlib-devel openssl-devel
debian:apt-get install zlib1g-dev

8、configure: error: libXpm.(a|so) not found.
apt-get install libxpm-dev

9、configure: error: freetype.h not found.
apt-get install libfreetype6-dev

10、configure: error: ...No recognized SSL/TLS toolkit detected
apt-get install libssl-dev

11、 Configure: error: xml2-config not found. Please check your libxml2 installation.
yum install libxml2 libxml2-devel (For Redhat & Fedora)
# aptitude install libxml2-dev (For ubuntu)

12、 Checking for pkg-config… /usr/bin/pkg-config
configure: error: Cannot find OpenSSL’s
yum install openssl openssl-devel

13、 Configure: error: Please reinstall the BZip2 distribution
yum install bzip2 bzip2-devel

14、 Configure: error: Please reinstall the libcurl distribution -easy.h should be in /include/curl/
#yum install curl curl-devel (For Redhat & Fedora)
#install libcurl4-gnutls-dev (For Ubuntu)

15、Configure: error: libjpeg.(also) not found.
yum -y install gd
yum -y install gd-devel
yum install libjpeg libjpeg-devel

16、 Configure: error: libpng.(also) not found.
yum install libpng libpng-devel
apt-get install libpng12-dev

17、 Configure: error: freetype.h not found.
yum install freetype-devel

18、Configure: error: Unable to locate gmp.h
yum install gmp-devel

19、 Configure: error: Cannot find MySQL header files under /usr.Note that the MySQL client library is not bundled anymore!
yum install mysql-devel (For Redhat & Fedora)
# apt-get install libmysql++-dev (For Ubuntu)

20、Configure: error: Please reinstall the ncurses distribution
yum install ncurses ncurses-devel

21、 Checking for unixODBC support… configure: error: ODBC header file ‘/usr/include/sqlext.h’ not found!
yum install unixODBC-devel

22、 Configure: error: Cannot find pspell
yum install pspell-devel

23、 configure: error: mcrypt.h not found. Please reinstall libmcrypt.
yum install libmcrypt libmcrypt-devel (For Redhat & Fedora)
# apt-get install libmcrypt-dev

24、 Configure: error: snmp.h not found. Check your SNMP installation.
yum install net-snmp net-snmp-devel

25、开启LDAP服务还需要
yum -y install openldap-devel openldap-servers openldap-clients

26、configure: error: No curses/termcap library found
网上有的说法是:
–with-named-curses-libs=/usr/lib/libncursesw.so.5
其实是不对的,虽然能解决configure的错误,但是make的时候会提示错误,正确的做法应该是
yum -y install ncurses-devel (for redhat)
apt-get install libncurses5-dev(for debian)

27、configure: error: cannot find output from lex; giving up
yum -y install flex

28、configure: error: mod_deflate has been requested but can not be built due to prerequisite failures
yum -y install zlib-devel openssl-devel
debian:apt-get install zlib1g-dev

29、configure: error: libXpm.(a|so) not found.
apt-get install libxpm-dev

最终可以编译安装后可以看到欢迎界面:

image

赞(0) 打赏
未经允许不得转载:未来往事的博客 » Zabbix编译常见报错解决办法

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏